summaryrefslogtreecommitdiffstats
path: root/lass/2configs/bitcoin.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-08-06 16:10:01 +0200
committerlassulus <lassulus@lassul.us>2017-08-10 12:54:04 +0200
commit35a43cd74b7f0f4f9b53c6af1062d07c47bc80a5 (patch)
tree33b86fcea85560d2dc94313ed3d3248ab5ee2b66 /lass/2configs/bitcoin.nix
parent61968bc0263f8bbd92e167e4fde8290ba6cde12b (diff)
l bitcoin: add stuff for all the coins
Diffstat (limited to 'lass/2configs/bitcoin.nix')
-rw-r--r--lass/2configs/bitcoin.nix27
1 files changed, 24 insertions, 3 deletions
diff --git a/lass/2configs/bitcoin.nix b/lass/2configs/bitcoin.nix
index 2f4cd571..a405addf 100644
--- a/lass/2configs/bitcoin.nix
+++ b/lass/2configs/bitcoin.nix
@@ -3,11 +3,24 @@
let
mainUser = config.users.extraUsers.mainUser;
in {
- environment.systemPackages = with pkgs; [
- electrum
- ];
+ krebs.per-user.bch.packages = [
+ pkgs.electron-cash
+ ];
+ krebs.per-user.bitcoin.packages = [
+ pkgs.electrum
+ ];
+ krebs.per-user.ethereum.packages = [
+ pkgs.go-ethereum
+ ];
users.extraUsers = {
+ bch = {
+ name = "bch";
+ description = "user for bch stuff";
+ home = "/home/bch";
+ useDefaultShell = true;
+ createHome = true;
+ };
bitcoin = {
name = "bitcoin";
description = "user for bitcoin stuff";
@@ -15,8 +28,16 @@ in {
useDefaultShell = true;
createHome = true;
};
+ ethereum = {
+ name = "ethereum";
+ description = "user for ethereum stuff";
+ home = "/home/ethereum";
+ useDefaultShell = true;
+ createHome = true;
+ };
};
security.sudo.extraConfig = ''
${mainUser.name} ALL=(bitcoin) NOPASSWD: ALL
+ ${mainUser.name} ALL=(bch) NOPASSWD: ALL
'';
}