summaryrefslogtreecommitdiffstats
path: root/lass/1systems/styx/physical.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2020-11-23 11:32:23 +0100
committerlassulus <lassulus@lassul.us>2020-11-23 11:32:33 +0100
commit636d1eb762aae20e1da580d6f37460aa25391f45 (patch)
tree47d51848df727b993fe962d766920f470a5f0674 /lass/1systems/styx/physical.nix
parentd9dfd892bfd410afad5722363c9f297ad4075175 (diff)
l: init styx.r
Diffstat (limited to 'lass/1systems/styx/physical.nix')
-rw-r--r--lass/1systems/styx/physical.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/lass/1systems/styx/physical.nix b/lass/1systems/styx/physical.nix
new file mode 100644
index 00000000..a3899f87
--- /dev/null
+++ b/lass/1systems/styx/physical.nix
@@ -0,0 +1,34 @@
+{ config, lib, pkgs, ... }:
+
+{
+ imports = [
+ ./config.nix
+ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "usbhid" "sd_mod" ];
+ boot.initrd.kernelModules = [ "dm-snapshot" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ boot.loader.grub.enable = true;
+ boot.loader.grub.efiSupport = true;
+ boot.loader.grub.device = "/dev/disk/by-id/ata-SanDisk_SSD_G5_BICS4_20248F446514";
+ boot.loader.grub.efiInstallAsRemovable = true;
+
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/ee5c9099-17fa-401e-852e-67cb4ae068f4";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/EAA5-88A9";
+ fsType = "vfat";
+ };
+
+ swapDevices = [ ];
+
+ nix.maxJobs = lib.mkDefault 4;
+ powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}