summaryrefslogtreecommitdiffstats
path: root/lass/1systems/shodan/physical.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2018-05-12 15:51:24 +0200
committerlassulus <lassulus@lassul.us>2018-05-12 15:51:24 +0200
commit0c0d527bec3a6a3d6435203253edb2ef27f9655b (patch)
treec557aa36ab0eb475bab5c78c046caea3610f84bf /lass/1systems/shodan/physical.nix
parent079396f9e11573228bd6cf498f161c49660a7549 (diff)
l: hw config into physical.nix
Diffstat (limited to 'lass/1systems/shodan/physical.nix')
-rw-r--r--lass/1systems/shodan/physical.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/lass/1systems/shodan/physical.nix b/lass/1systems/shodan/physical.nix
new file mode 100644
index 00000000..4a550d0a
--- /dev/null
+++ b/lass/1systems/shodan/physical.nix
@@ -0,0 +1,47 @@
+{
+ #TODO reinstall with correct layout and use lass/hw/x220
+ imports = [
+ ./config.nix
+ <stockholm/krebs/2configs/hw/x220.nix>
+ ];
+
+ boot = {
+ loader.grub.enable = true;
+ loader.grub.version = 2;
+ loader.grub.device = "/dev/sda";
+
+ initrd.luks.devices = [ { name = "luksroot"; device = "/dev/sda2"; } ];
+ initrd.luks.cryptoModules = [ "aes" "sha512" "sha1" "xts" ];
+ initrd.availableKernelModules = [ "xhci_hcd" "ehci_pci" "ahci" "usb_storage" ];
+ #kernelModules = [ "kvm-intel" "msr" ];
+ };
+ fileSystems = {
+ "/" = {
+ device = "/dev/pool/nix";
+ fsType = "btrfs";
+ };
+
+ "/boot" = {
+ device = "/dev/sda1";
+ };
+ "/home" = {
+ device = "/dev/mapper/pool-home";
+ fsType = "btrfs";
+ options = ["defaults" "noatime" "ssd" "compress=lzo"];
+ };
+ "/tmp" = {
+ device = "tmpfs";
+ fsType = "tmpfs";
+ options = ["nosuid" "nodev" "noatime"];
+ };
+ "/bku" = {
+ device = "/dev/pool/bku";
+ fsType = "btrfs";
+ };
+ };
+
+ services.udev.extraRules = ''
+ SUBSYSTEM=="net", ATTR{address}=="a0:88:b4:29:26:bc", NAME="wl0"
+ SUBSYSTEM=="net", ATTR{address}=="f0:de:f1:0c:a7:63", NAME="et0"
+ '';
+}