summaryrefslogtreecommitdiffstats
path: root/lass/1systems/prism/config.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-08-16 11:36:34 +0200
committerlassulus <lassulus@lassul.us>2017-08-16 11:36:55 +0200
commitc4940d5926bcd2e938b914568161f63125926369 (patch)
tree57c107f17595e24fd4167091942594d6af19cd32 /lass/1systems/prism/config.nix
parent9fc1e0fba24ecfc765dedd966c0dcb6395aa1da9 (diff)
l prism.r: add container for kaepsele
Diffstat (limited to 'lass/1systems/prism/config.nix')
-rw-r--r--lass/1systems/prism/config.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/lass/1systems/prism/config.nix b/lass/1systems/prism/config.nix
index 5d05ae39..744bae55 100644
--- a/lass/1systems/prism/config.nix
+++ b/lass/1systems/prism/config.nix
@@ -298,6 +298,22 @@ in {
localAddress = "10.233.2.2";
};
}
+ {
+ #kaepsele
+ containers.kaepsele = {
+ config = { ... }: {
+ services.openssh.enable = true;
+ users.users.root.openssh.authorizedKeys.keys = with config.krebs.users; [
+ lass.pubkey
+ tv.pubkey
+ ];
+ };
+ enableTun = true;
+ privateNetwork = true;
+ hostAddress = "10.233.2.3";
+ localAddress = "10.233.2.4";
+ };
+ }
];
krebs.build.host = config.krebs.hosts.prism;