summaryrefslogtreecommitdiffstats
path: root/lass/1systems/prism/config.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-09-09 00:21:13 +0200
committerlassulus <lassulus@lassul.us>2017-09-09 00:21:13 +0200
commitb01f595289fdcd5b6d4c69b335ea0b3645741189 (patch)
tree3322504312c33d203a7a4c6c9550b392edcaac0d /lass/1systems/prism/config.nix
parentaeb49b367430f36c598024f0213bfc92ff65a06f (diff)
l prism.r: add onondaga container
Diffstat (limited to 'lass/1systems/prism/config.nix')
-rw-r--r--lass/1systems/prism/config.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/lass/1systems/prism/config.nix b/lass/1systems/prism/config.nix
index b3f54745..5983456b 100644
--- a/lass/1systems/prism/config.nix
+++ b/lass/1systems/prism/config.nix
@@ -311,6 +311,22 @@ in {
localAddress = "10.233.2.4";
};
}
+ {
+ #onondaga
+ containers.onondaga = {
+ config = { ... }: {
+ services.openssh.enable = true;
+ users.users.root.openssh.authorizedKeys.keys = [
+ config.krebs.users.lass.pubkey
+ config.krebs.users.nin.pubkey
+ ];
+ };
+ enableTun = true;
+ privateNetwork = true;
+ hostAddress = "10.233.2.4";
+ localAddress = "10.233.2.5";
+ };
+ }
];
krebs.build.host = config.krebs.hosts.prism;