summaryrefslogtreecommitdiffstats
path: root/lass/1systems/mors/config.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2019-04-18 10:16:02 +0200
committerlassulus <lassulus@lassul.us>2019-04-18 10:16:02 +0200
commit2a89d6587d5ee5d3151b5e5be05e152a539e78d0 (patch)
treeb62c261b932b1dae51728933235613b8d0a726ec /lass/1systems/mors/config.nix
parent3adcf3a74c00b5e88b8c8c15d6aeb9ab3f9304db (diff)
l syncs: use permown, use attrs
Diffstat (limited to 'lass/1systems/mors/config.nix')
-rw-r--r--lass/1systems/mors/config.nix15
1 files changed, 9 insertions, 6 deletions
diff --git a/lass/1systems/mors/config.nix b/lass/1systems/mors/config.nix
index 7e183f40..f911b79d 100644
--- a/lass/1systems/mors/config.nix
+++ b/lass/1systems/mors/config.nix
@@ -49,12 +49,15 @@ with import <stockholm/lib>;
];
}
{
- krebs.syncthing.folders = [
- { id = "the_playlist"; path = "/home/lass/tmp/the_playlist"; peers = [ "mors" "phone" "prism" ]; }
- ];
- lass.ensure-permissions = [
- { folder = "/home/lass/tmp/the_playlist"; owner = "lass"; group = "syncthing"; }
- ];
+ krebs.syncthing.folders."the_playlist" = {
+ path = "/home/lass/tmp/the_playlist";
+ peers = [ "mors" "phone" "prism" ];
+ };
+ krebs.permown."/home/lass/tmp/the_playlist" = {
+ owner = "lass";
+ group = "syncthing";
+ umask = "0007";
+ };
}
{
lass.umts = {