summaryrefslogtreecommitdiffstats
path: root/lass/1systems/mors/config.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2018-04-05 19:31:39 +0200
committerlassulus <lassulus@lassul.us>2018-04-05 19:31:39 +0200
commit1dd03483619d00d1afc6a278ded0cca6cff2d9ed (patch)
treea38096bd38ebbbae985afe2643aa7d0743a5f417 /lass/1systems/mors/config.nix
parent665ea5674e0d99f51379d24829436773b9dc2769 (diff)
add minimal working kops for stockholm
Diffstat (limited to 'lass/1systems/mors/config.nix')
-rw-r--r--lass/1systems/mors/config.nix8
1 files changed, 1 insertions, 7 deletions
diff --git a/lass/1systems/mors/config.nix b/lass/1systems/mors/config.nix
index 8e805baf..cd259d0f 100644
--- a/lass/1systems/mors/config.nix
+++ b/lass/1systems/mors/config.nix
@@ -168,14 +168,8 @@ with import <stockholm/lib>;
environment.shellAliases = {
deploy = pkgs.writeDash "deploy" ''
set -eu
- export PATH=${makeBinPath [
- pkgs.bash
- pkgs.coreutils
- pkgs.nixUnstable
- ]}
- cd ~/stockholm
export SYSTEM="$1"
- exec nix-shell -I stockholm="$PWD" --run 'deploy --system="$SYSTEM"'
+ $(nix-build $HOME/stockholm/lass/kops.nix --no-out-link --argstr name "$SYSTEM" -A deploy)
'';
};