summaryrefslogtreecommitdiffstats
path: root/lass/1systems/iso.nix
diff options
context:
space:
mode:
authorlassulus <lass@lassul.us>2017-04-19 00:13:52 +0200
committerlassulus <lass@lassul.us>2017-04-19 00:13:52 +0200
commitd40738d41573eca83d7e84f8a9946f8d8441a0d0 (patch)
tree52999470ce5c2b0bacf4240d609c23b6c84892e2 /lass/1systems/iso.nix
parentd528daf9e8d4ec59b3e5355576eaf001136763cc (diff)
l 1 iso: hack around buggy /dev/stderr in live iso
Diffstat (limited to 'lass/1systems/iso.nix')
-rw-r--r--lass/1systems/iso.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/lass/1systems/iso.nix b/lass/1systems/iso.nix
index 5bbd0c1d..99399550 100644
--- a/lass/1systems/iso.nix
+++ b/lass/1systems/iso.nix
@@ -12,6 +12,27 @@ with import <stockholm/lib>;
../2configs/nixpkgs.nix
../2configs/vim.nix
{
+ # /dev/stderr doesn't work. I don't know why
+ # /proc/self doesn't seem to work correctly
+ # /dev/pts is empty except for 1 file
+ # my life sucks
+ nixpkgs.config.packageOverrides = super: {
+ irc-announce = super.callPackage <stockholm/krebs/5pkgs/irc-announce> {
+ pkgs = pkgs // { coreutils = pkgs.concat "coreutils-hack" [
+ pkgs.coreutils
+ (pkgs.writeDashBin "tee" ''
+ if test "$1" = /dev/stderr; then
+ while read -r line; do
+ echo "$line"
+ echo "$line" >&2
+ done
+ else
+ ${super.coreutils}/bin/tee "$@"
+ fi
+ '')
+ ];};
+ };
+ };
boot.kernelParams = [ "copytoram" ];
}
{