summaryrefslogtreecommitdiffstats
path: root/lass/1systems/dishfire/physical.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2021-11-24 08:27:30 +0100
committermakefu <github@syntax-fehler.de>2021-11-24 08:27:30 +0100
commitd2776a87a51bbc63957ee2e590f18a7425a87987 (patch)
tree7052993633e46defc64737aff54d0272a8ce75c1 /lass/1systems/dishfire/physical.nix
parent60b7a7bded68ebd3a5d76b6e0374e189f3a64300 (diff)
parent4c7abec39771cbd47dc091c674a0429f5c757ebc (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lass/1systems/dishfire/physical.nix')
-rw-r--r--lass/1systems/dishfire/physical.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/lass/1systems/dishfire/physical.nix b/lass/1systems/dishfire/physical.nix
new file mode 100644
index 00000000..ca013132
--- /dev/null
+++ b/lass/1systems/dishfire/physical.nix
@@ -0,0 +1,21 @@
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports = [
+ ./config.nix
+ (modulesPath + "/profiles/qemu-guest.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "ata_piix" "virtio_pci" "xhci_pci" "sd_mod" "sr_mod" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ ];
+ boot.extraModulePackages = [ ];
+ boot.loader.grub.devices = [ "/dev/sda" ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/84053adc-49bc-4e02-8a19-3838bf3a43fd";
+ fsType = "ext4";
+ };
+
+ swapDevices = [ ];
+}