summaryrefslogtreecommitdiffstats
path: root/lass/1systems/coaxmetal/physical.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2021-02-18 19:57:38 +0100
committerlassulus <lassulus@lassul.us>2021-02-18 19:57:38 +0100
commit1580aca24d352eaf649305e367ad92537b25f314 (patch)
tree5cba717761d77a18987a87a93ef11098457b7f24 /lass/1systems/coaxmetal/physical.nix
parentac10edb22a05258326ac7a84571c09147f603a09 (diff)
l: init coaxmetal.rtest
Diffstat (limited to 'lass/1systems/coaxmetal/physical.nix')
-rw-r--r--lass/1systems/coaxmetal/physical.nix52
1 files changed, 52 insertions, 0 deletions
diff --git a/lass/1systems/coaxmetal/physical.nix b/lass/1systems/coaxmetal/physical.nix
new file mode 100644
index 00000000..c94740c5
--- /dev/null
+++ b/lass/1systems/coaxmetal/physical.nix
@@ -0,0 +1,52 @@
+{ config, lib, pkgs, modulesPath, ... }:
+{
+ imports = [
+ ./config.nix
+ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ networking.hostId = "e0c335ea";
+ boot.zfs.requestEncryptionCredentials = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+ boot.loader.grub = {
+ enable = true;
+ # device = "/dev/disk/by-id/nvme-WDC_PC_SN730_SDBQNTY-1T00-1001_205349800040";
+ device = "nodev";
+ efiSupport = true;
+ # efiInstallAsRemovable = true;
+ };
+
+ services.xserver.videoDrivers = [
+ "amdgpu"
+ ];
+
+ hardware.opengl.extraPackages = [ pkgs.amdvlk ];
+ # is required for amd graphics support ( xorg wont boot otherwise )
+ boot.kernelPackages = pkgs.linuxPackages_latest;
+ environment.variables.VK_ICD_FILENAMES =
+ "/run/opengl-driver/share/vulkan/icd.d/amd_icd64.json";
+
+ boot.initrd.availableKernelModules = [ "nvme" "ehci_pci" "xhci_pci" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
+ boot.kernelModules = [ "kvm-amd" ];
+
+ fileSystems."/" = {
+ device = "zpool/root/root";
+ fsType = "zfs";
+ };
+
+ fileSystems."/home" = {
+ device = "zpool/root/home";
+ fsType = "zfs";
+ };
+
+ fileSystems."/boot" = {
+ device = "/dev/disk/by-uuid/50A7-1889";
+ fsType = "vfat";
+ };
+
+ services.logind.lidSwitch = "ignore";
+ services.logind.lidSwitchDocked = "ignore";
+ boot.extraModprobeConfig = ''
+ options psmouse proto=imps
+ '';
+}