summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/prison-break/straight-plugin.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2019-05-14 19:02:02 +0200
committerjeschli <jeschli@gmail.com>2019-05-14 19:02:02 +0200
commite869a8a82ad32aacf235b846c4d14a1791745c56 (patch)
tree1ff8687992a78a39513acd1c6da13adc794d0abc /krebs/5pkgs/simple/prison-break/straight-plugin.nix
parent3899d0195c6077174e2d416c490dfae8783acee5 (diff)
parente9f96d7757f48000c6c4a4c1317bf4debab16a27 (diff)
Merge branch 'master' of prism.r:stockholm
Diffstat (limited to 'krebs/5pkgs/simple/prison-break/straight-plugin.nix')
-rw-r--r--krebs/5pkgs/simple/prison-break/straight-plugin.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/prison-break/straight-plugin.nix b/krebs/5pkgs/simple/prison-break/straight-plugin.nix
new file mode 100644
index 00000000..606c60b5
--- /dev/null
+++ b/krebs/5pkgs/simple/prison-break/straight-plugin.nix
@@ -0,0 +1,22 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+}:
+
+buildPythonPackage rec {
+ pname = "straight-plugin";
+ version = "1.5.0";
+
+ src = fetchPypi {
+ pname = "straight.plugin";
+ inherit version;
+ sha256 = "818a7641068932ed6436d0af0a3bb77bbbde29df0a7142c8bd1a249e7c2f0d38";
+ };
+
+ meta = with lib; {
+ description = "A simple namespaced plugin facility";
+ homepage = https://github.com/ironfroggy/straight.plugin;
+ license = licenses.mit;
+ maintainers = [ maintainers.makefu ];
+ };
+}