summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/prison-break/straight-plugin.nix
diff options
context:
space:
mode:
authormagenbluten <magenbluten@codemonkey.cc>2019-05-21 19:52:44 +0200
committermagenbluten <magenbluten@codemonkey.cc>2019-05-21 19:52:44 +0200
commit09552a6945bd4207c5f44b7aebd7142e7e766d83 (patch)
treea53914e3f1e286053fc64ad1d87075d2210dae25 /krebs/5pkgs/simple/prison-break/straight-plugin.nix
parentc74d86cf6a1299ba0a11fcfb2341a8632b147420 (diff)
parent73997358e457b51c72d954546451008560a4adfc (diff)
Merge remote-tracking branch 'origin/master'
Diffstat (limited to 'krebs/5pkgs/simple/prison-break/straight-plugin.nix')
-rw-r--r--krebs/5pkgs/simple/prison-break/straight-plugin.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/prison-break/straight-plugin.nix b/krebs/5pkgs/simple/prison-break/straight-plugin.nix
new file mode 100644
index 00000000..606c60b5
--- /dev/null
+++ b/krebs/5pkgs/simple/prison-break/straight-plugin.nix
@@ -0,0 +1,22 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+}:
+
+buildPythonPackage rec {
+ pname = "straight-plugin";
+ version = "1.5.0";
+
+ src = fetchPypi {
+ pname = "straight.plugin";
+ inherit version;
+ sha256 = "818a7641068932ed6436d0af0a3bb77bbbde29df0a7142c8bd1a249e7c2f0d38";
+ };
+
+ meta = with lib; {
+ description = "A simple namespaced plugin facility";
+ homepage = https://github.com/ironfroggy/straight.plugin;
+ license = licenses.mit;
+ maintainers = [ maintainers.makefu ];
+ };
+}