summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/passwdqc-utils
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-05-24 01:43:50 +0200
committertv <tv@krebsco.de>2017-05-24 01:43:50 +0200
commitf0b98bd0114df1e1ebb82ff300f9532d86b3eb18 (patch)
tree58a39173f7d6d7caa10a7b8fec1b5a1e54f0c08c /krebs/5pkgs/simple/passwdqc-utils
parent46d6506916f699e3b707dc41cd68c92b98e50e5a (diff)
krebs/5pkgs: move simple pkgs to a subdir
Diffstat (limited to 'krebs/5pkgs/simple/passwdqc-utils')
-rw-r--r--krebs/5pkgs/simple/passwdqc-utils/default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/passwdqc-utils/default.nix b/krebs/5pkgs/simple/passwdqc-utils/default.nix
new file mode 100644
index 00000000..53e7f548
--- /dev/null
+++ b/krebs/5pkgs/simple/passwdqc-utils/default.nix
@@ -0,0 +1,37 @@
+{ stdenv, pam,
+ fetchurl, lib,
+ wordset-file ? null, # set your own wordset-file
+ ... }:
+
+stdenv.mkDerivation rec {
+ name = "passwdqc-utils-${version}";
+ version = "1.3.0";
+ buildInputs = [ pam ];
+
+ src = fetchurl {
+ url = "http://www.openwall.com/passwdqc/passwdqc-${version}.tar.gz";
+ sha256 = "0l3zbrp4pvah0dz33m48aqlz9nx663cc1fqhnlwr0p853b10la93";
+ };
+
+ buildTargets = "utils";
+ installFlags= [ "BINDIR=$(out)/bin"
+ "CONFDIR=$(out)/etc"
+ "SHARED_LIBDIR=$(out)/lib"
+ "DEVEL_LIBDIR=$(out)/lib"
+ "SECUREDIR=$(out)/lib/security"
+ "INCLUDEDIR=$(out)/include"
+ "MANDIR=$(out)/man" ];
+
+ patchPhase = lib.optionalString (wordset-file != null) ''
+ cp -f ${wordset-file} wordset_4k.c
+ '';
+
+ installTargets = "install_lib install_utils";
+
+ meta = {
+ description = "passwdqc utils (pwqgen,pwqcheck) and library";
+ license = stdenv.lib.licenses.bsd3;
+ maintainers = [ stdenv.lib.maintainers.makefu ];
+ patforms = stdenv.lib.platforms.linux; # more installFlags must be set for Darwin,Solaris
+ };
+}