summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/netcup
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-05-24 01:43:50 +0200
committertv <tv@krebsco.de>2017-05-24 01:43:50 +0200
commitf0b98bd0114df1e1ebb82ff300f9532d86b3eb18 (patch)
tree58a39173f7d6d7caa10a7b8fec1b5a1e54f0c08c /krebs/5pkgs/simple/netcup
parent46d6506916f699e3b707dc41cd68c92b98e50e5a (diff)
krebs/5pkgs: move simple pkgs to a subdir
Diffstat (limited to 'krebs/5pkgs/simple/netcup')
-rw-r--r--krebs/5pkgs/simple/netcup/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/netcup/default.nix b/krebs/5pkgs/simple/netcup/default.nix
new file mode 100644
index 00000000..d1f46299
--- /dev/null
+++ b/krebs/5pkgs/simple/netcup/default.nix
@@ -0,0 +1,32 @@
+{ coreutils, curl, fetchgit, gawk, gnugrep, gnused, jq, stdenv, w3m, ... }:
+with import <stockholm/lib>;
+let
+ readJSON = path: fromJSON (readFile path);
+ sed.escape = replaceChars ["/"] ["\\/"]; # close enough
+ PATH = makeBinPath [
+ coreutils
+ curl
+ gawk
+ gnugrep
+ gnused
+ jq
+ w3m
+ ];
+in
+stdenv.mkDerivation {
+ name = "netcup-1.0.0";
+ src = fetchgit {
+ url = "http://cgit.ni.krebsco.de/netcup";
+ rev = "refs/tags/v1.0.0";
+ sha256 = "1rn7bncfhjw0bqjbvj38m7lks4nyf5qcvkj9dg0zr99ba6dylzx5";
+ };
+ phases = [ "unpackPhase" "patchPhase" "installPhase" ];
+ patchPhase = ''
+ path=${shell.escape (sed.escape PATH)}
+ sed -i "1s/.*/&\nPATH=$path/" vcp
+ '';
+ installPhase = ''
+ mkdir -p $out/bin
+ cp vcp $out/bin
+ '';
+}