summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/git-hooks
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2018-09-06 23:02:56 +0200
committertv <tv@krebsco.de>2018-09-06 23:02:56 +0200
commitaa04423e3a313271fca4d951d8717459e7969d60 (patch)
tree06695502d941bb023e495164fc4630207567c6f2 /krebs/5pkgs/simple/git-hooks
parentdb5921f163c59673ae0307088cd14bdda836c6d8 (diff)
irc-announce: whitelist refs instead of branches
Diffstat (limited to 'krebs/5pkgs/simple/git-hooks')
-rw-r--r--krebs/5pkgs/simple/git-hooks/default.nix15
1 files changed, 8 insertions, 7 deletions
diff --git a/krebs/5pkgs/simple/git-hooks/default.nix b/krebs/5pkgs/simple/git-hooks/default.nix
index 1930c7f1..0a2c8441 100644
--- a/krebs/5pkgs/simple/git-hooks/default.nix
+++ b/krebs/5pkgs/simple/git-hooks/default.nix
@@ -6,11 +6,11 @@ with import <stockholm/lib>;
# TODO irc-announce should return a derivation
# but it cannot because krebs.git.repos.*.hooks :: attrsOf str
irc-announce =
- { branches ? []
- , cgit_endpoint ? "http://cgit.${nick}.r"
+ { cgit_endpoint ? "http://cgit.${nick}.r"
, channel
, nick
, port ? 6667
+ , refs ? []
, server
, verbose ? false
}: /* sh */ ''
@@ -57,14 +57,15 @@ with import <stockholm/lib>;
receive_mode=non-fast-forward
fi
- h=$(echo $ref | sed 's:^refs/heads/::')
-
- ${optionalString (branches != []) ''
- if ! (echo "$h" | grep -qE "${concatStringsSep "|" branches}"); then
- echo "we are not serving this branch: $h"
+ ${optionalString (refs != []) ''
+ if ! { echo "$ref" | grep -qE "${concatStringsSep "|" refs}"; }; then
+ echo "we are not announcing this ref: $h"
exit 0
fi
''}
+
+ h=$(echo $ref | sed 's:^refs/heads/::')
+
# empty_tree=$(git hash-object -t tree /dev/null)
empty_tree=4b825dc6