summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/buildbot-classic
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-07-25 23:10:51 +0200
committerlassulus <lassulus@lassul.us>2017-07-25 23:18:38 +0200
commit7aa31b7babafb2e10bbf8418800ef561bccbd67b (patch)
treec0d87b752e939d07facb64f1d69a569c963a773c /krebs/5pkgs/simple/buildbot-classic
parent826da6c222d359ede5d032173c204bf37715cdc8 (diff)
krebs buildbot: reintroduce packages with minimal overrides
Diffstat (limited to 'krebs/5pkgs/simple/buildbot-classic')
-rw-r--r--krebs/5pkgs/simple/buildbot-classic/default.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/buildbot-classic/default.nix b/krebs/5pkgs/simple/buildbot-classic/default.nix
new file mode 100644
index 00000000..c28f77ef
--- /dev/null
+++ b/krebs/5pkgs/simple/buildbot-classic/default.nix
@@ -0,0 +1,47 @@
+{ fetchgit, fetchFromGitHub, python2Packages, ... }:
+let
+ # https://github.com/NixOS/nixpkgs/issues/14026
+ nixpkgs-fix = import (fetchgit {
+ url = https://github.com/nixos/nixpkgs;
+ rev = "e026b5c243ea39810826e68362718f5d703fb5d0";
+ sha256 = "11lqd480bi6xbi7xbh4krrxmbp6a6iafv1d0q3sj461al0x0has8";
+ }) {};
+
+in nixpkgs-fix.buildPythonApplication {
+ name = "buildbot-0.8.12";
+ namePrefix = "";
+ patches = [];
+
+ src = fetchFromGitHub {
+ owner = "krebscode";
+ repo = "buildbot-classic";
+ rev = "5b4f5f6f1";
+ sha256 = "1j3xn1gjzvsf90jvfmyln71fzlhjx642ivrqf47zfxpkacljja93";
+ };
+ postUnpack = "sourceRoot=\${sourceRoot}/master";
+
+ patchPhase =
+ # The code insists on /usr/bin/tail, /usr/bin/make, etc.
+ '' echo "patching erroneous absolute path references..."
+ for i in $(find -name \*.py)
+ do
+ sed -i "$i" \
+ -e "s|/usr/bin/python|$(type -P python)|g ; s|/usr/bin/||g"
+ done
+
+ sed -i 's/==/>=/' setup.py
+ '';
+
+ propagatedBuildInputs = [
+ python2Packages.jinja2
+ python2Packages.twisted
+ nixpkgs-fix.pythonPackages.dateutil_1_5
+ nixpkgs-fix.pythonPackages.sqlalchemy_migrate_0_7
+ ];
+ doCheck = false;
+ postInstall = ''
+ mkdir -p "$out/share/man/man1"
+ cp docs/buildbot.1 "$out/share/man/man1"
+ '';
+}
+