summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-12-05 22:36:03 +0100
committertv <tv@krebsco.de>2017-12-05 22:36:03 +0100
commitd039cd9f487bac52e598f6a715924c58315a1e0a (patch)
tree9981cbfb8e84aeceeb439914f53d85a28488149c /krebs/5pkgs/haskell
parent3ae89eddab58078f8d06cdda330c24f74a439096 (diff)
haskellPackages.nix-diff: init at 1.0.0
Diffstat (limited to 'krebs/5pkgs/haskell')
-rw-r--r--krebs/5pkgs/haskell/nix-diff.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell/nix-diff.nix b/krebs/5pkgs/haskell/nix-diff.nix
new file mode 100644
index 00000000..2070dbd2
--- /dev/null
+++ b/krebs/5pkgs/haskell/nix-diff.nix
@@ -0,0 +1,22 @@
+{ mkDerivation, attoparsec, base, containers, Diff, fetchgit, mtl
+, nix-derivation, optparse-generic, stdenv, system-filepath, text
+, unix, vector
+}:
+mkDerivation {
+ pname = "nix-diff";
+ version = "1.0.0";
+ src = fetchgit {
+ url = "https://github.com/Gabriel439/nix-diff";
+ sha256 = "1k00nx8pannqmpzadkwfrs6bf79yk22ynhd033z5rsyw0m8fcz9k";
+ rev = "e32ffa2c7f38b47a71325a042c1d887fb46cdf7d";
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ attoparsec base containers Diff mtl nix-derivation optparse-generic
+ system-filepath text unix vector
+ ];
+ homepage = "https://github.com/Gabriel439/nix-diff";
+ description = "Explain why two Nix derivations differ";
+ license = stdenv.lib.licenses.bsd3;
+}