summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/much.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2019-01-25 19:41:00 +0100
committerlassulus <lassulus@lassul.us>2019-01-25 19:41:00 +0100
commitd0a55575fae843edf18d5d82b06697595cbf743b (patch)
treec2a0fe97ba2590cb8dcfe1534c68feba9997a757 /krebs/5pkgs/haskell/much.nix
parent1f6b43acbda232fd8836b937909120dc7335a16a (diff)
parentb3c65141b8179dddbfdcd783e14a20575be5d2e2 (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'krebs/5pkgs/haskell/much.nix')
-rw-r--r--krebs/5pkgs/haskell/much.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell/much.nix b/krebs/5pkgs/haskell/much.nix
new file mode 100644
index 00000000..db168f8a
--- /dev/null
+++ b/krebs/5pkgs/haskell/much.nix
@@ -0,0 +1,29 @@
+{ mkDerivation, aeson, attoparsec, base, base64-bytestring
+, blaze-builder, blessings, bytestring, case-insensitive
+, containers, deepseq, directory, docopt, email-header, fetchgit
+, filepath, friendly-time, hyphenation, linebreak, old-locale
+, process, random, rosezipper, safe, scanner, split, stdenv
+, terminal-size, text, time, transformers, transformers-compat
+, unix, vector
+}:
+mkDerivation {
+ pname = "much";
+ version = "1.2.0";
+ src = fetchgit {
+ url = "https://cgit.krebsco.de/much";
+ sha256 = "0gfvppi8acylz0q7xh8dkm3dj676d4sc1m1gxwp663bkn4748873";
+ rev = "8fc4fbb5bb7781626da8f63cd8df8bb0f554cfe7";
+ fetchSubmodules = true;
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson attoparsec base base64-bytestring blaze-builder blessings
+ bytestring case-insensitive containers deepseq directory docopt
+ email-header filepath friendly-time hyphenation linebreak
+ old-locale process random rosezipper safe scanner split
+ terminal-size text time transformers transformers-compat unix
+ vector
+ ];
+ license = stdenv.lib.licenses.mit;
+}