summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/blessings.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2021-11-07 14:31:25 +0100
committermakefu <github@syntax-fehler.de>2021-11-07 14:31:25 +0100
commit597f546e9833b2569ee6ec540f688f7fb95bd26c (patch)
treee7393bb0aea4faee24e85e63d82843bd3b9a0bac /krebs/5pkgs/haskell/blessings.nix
parent9392c355ad5198346313ef0972db1910c10d17bf (diff)
parent0e668121a1388914f33a6546c2f63adc212a38c4 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'krebs/5pkgs/haskell/blessings.nix')
-rw-r--r--krebs/5pkgs/haskell/blessings.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/krebs/5pkgs/haskell/blessings.nix b/krebs/5pkgs/haskell/blessings.nix
index b0e81fdc..2176db2f 100644
--- a/krebs/5pkgs/haskell/blessings.nix
+++ b/krebs/5pkgs/haskell/blessings.nix
@@ -1,6 +1,7 @@
-with import <stockholm/lib>;
-{ mkDerivation, base, fetchgit, hspec, QuickCheck, stdenv, text }: let
+{ mkDerivation, base, fetchgit, hspec, QuickCheck, lib, stockholm, text }:
+with stockholm.lib;
+let
cfg = {
"18.03" = {
version = "1.1.0";
@@ -23,5 +24,5 @@ in mkDerivation {
testHaskellDepends = [ base hspec QuickCheck ];
doHaddock = false;
# WTFPL is the true license, which is unknown to cabal.
- license = stdenv.lib.licenses.wtfpl;
+ license = lib.licenses.wtfpl;
}