summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/upstream/window-managers/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2021-01-25 01:54:28 +0100
committertv <tv@krebsco.de>2021-01-26 20:54:47 +0100
commit6e9f5602a92933dafc1f6c0420aa4329cdd9a17d (patch)
tree2c39f3998ba9d06d15cf9757c282b47bc4dec7cd /krebs/3modules/upstream/window-managers/default.nix
parent21303714afa87ca3081a9fbc4585d86badc131bb (diff)
nixos/xmonad: import and make reloadable
Import nixos/modules/services/x11/window-managers/xmonad.nix from nixpkgs de121de16ef947bc8e8bfdaa37b5c6cc506050c6 and turn it into a user service that reloads xmonad whenever its configuration changes.
Diffstat (limited to 'krebs/3modules/upstream/window-managers/default.nix')
-rw-r--r--krebs/3modules/upstream/window-managers/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/krebs/3modules/upstream/window-managers/default.nix b/krebs/3modules/upstream/window-managers/default.nix
new file mode 100644
index 00000000..eecadca7
--- /dev/null
+++ b/krebs/3modules/upstream/window-managers/default.nix
@@ -0,0 +1,22 @@
+{
+ imports = [
+ # Replace upstream xmonad module with one that will be reloaded if changed.
+ #
+ # This module is intended to be upstreamed once fully tested.
+ # The patch to be committed can be obtained using:
+ #
+ # diff -u <nixpkgs/nixos/modules/services/x11/window-managers/xmonad.nix> \
+ # <stockholm/tv/3modules/window-managers/xmonad.nix>
+ #
+ {
+ disabledModules = [ "services/x11/window-managers/xmonad.nix" ];
+ imports = [ ./xmonad.nix ];
+ nixpkgs.overlays = [(self: super: {
+ writers = super.writers // {
+ writeHaskellBin = name: spec: with import <stockholm/lib>;
+ super.writers.writeHaskellBin name (removeAttrs spec ["ghcArgs"]);
+ };
+ })];
+ }
+ ];
+}