summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/reaktor2.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-04-22 00:30:37 +0200
committermakefu <github@syntax-fehler.de>2020-04-22 00:30:37 +0200
commitcb7ea9d84af46b606e5daa1252c60eb210d7e576 (patch)
tree5166a62dc73c45b3cd3b996078913588d1844266 /krebs/3modules/reaktor2.nix
parent0b371833e9ef68fd891fac65a657d8e38b5b3fad (diff)
parentc49867b40327f83a18b956404875637ca379c1ba (diff)
Merge remote-tracking branch 'lass/20.03' into 20.03
Diffstat (limited to 'krebs/3modules/reaktor2.nix')
-rw-r--r--krebs/3modules/reaktor2.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/krebs/3modules/reaktor2.nix b/krebs/3modules/reaktor2.nix
index 837a9bea..fcc453fa 100644
--- a/krebs/3modules/reaktor2.nix
+++ b/krebs/3modules/reaktor2.nix
@@ -45,6 +45,10 @@ with import <stockholm/lib>;
default = self.config.port == "6697";
type = types.bool;
};
+ API.listen = mkOption {
+ default = null;
+ type = types.nullOr types.str;
+ };
};
}));
};
@@ -65,9 +69,11 @@ with import <stockholm/lib>;
ExecStart = let
configFile = pkgs.writeJSON configFileName configValue;
configFileName = "${cfg.systemd-service-name}.config.json";
- configValue = recursiveUpdate {
- logTime = false;
- } (removeAttrs cfg ["_module"]);
+ configValue = stripAttr (
+ recursiveUpdate {
+ logTime = false;
+ } (removeAttrs cfg ["_module"])
+ );
in "${pkgs.reaktor2}/bin/reaktor ${configFile}";
Restart = "always";
RestartSec = "30";