summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/lass/default.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2018-12-09 17:02:50 +0100
committerlassulus <lassulus@lassul.us>2018-12-09 17:02:50 +0100
commitc739f81e5bd62a5dff2def3a45e7c0ac71b08f52 (patch)
tree2425e803b999ae10482cec92536541845f3c1aab /krebs/3modules/lass/default.nix
parenta289812df188ab45ee03aedea83d5a0c861594f1 (diff)
l: add wirelum to prism, mors, shodan, icarus, yellow
Diffstat (limited to 'krebs/3modules/lass/default.nix')
-rw-r--r--krebs/3modules/lass/default.nix41
1 files changed, 40 insertions, 1 deletions
diff --git a/krebs/3modules/lass/default.nix b/krebs/3modules/lass/default.nix
index fe63982b..adfa8dbe 100644
--- a/krebs/3modules/lass/default.nix
+++ b/krebs/3modules/lass/default.nix
@@ -89,11 +89,22 @@ in
-----END RSA PUBLIC KEY-----
'';
};
+ wirelum = {
+ via = internet;
+ ip4.addr = "10.244.1.1";
+ ip6.addr = (wip6 "1").address;
+ aliases = [
+ "prism.w"
+ ];
+ wireguard = {
+ pubkey = "oKJotppdEJqQBjrqrommEUPw+VFryvEvNJr/WikXohk=";
+ subnets = [ "10.244.1.0/24" (wip6 "1").subnetCIDR ];
+ };
+ };
};
ssh.privkey.path = <secrets/ssh.id_ed25519>;
ssh.pubkey = "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIAsANFdMi825qWQXQbWLYuNZ6/fARt3lnh1KStQHQQMD";
};
-
archprism = {
cores = 1;
nets = rec {
@@ -181,6 +192,13 @@ in
-----END RSA PUBLIC KEY-----
'';
};
+ wirelum = {
+ ip6.addr = (wip6 "dea7").address;
+ aliases = [
+ "mors.w"
+ ];
+ wireguard.pubkey = "FkcxMathQzJYwuJBli/nibh0C0kHe9/T2xU0za3J3SQ=";
+ };
};
secure = true;
ssh.privkey.path = <secrets/ssh.id_ed25519>;
@@ -207,6 +225,13 @@ in
-----END RSA PUBLIC KEY-----
'';
};
+ wirelum = {
+ ip6.addr = (wip6 "50da").address;
+ aliases = [
+ "shodan.w"
+ ];
+ wireguard.pubkey = "FkcxMathQzJYwuJBli/nibh0C0kHe9/T2xU0za4J3SQ=";
+ };
};
secure = true;
ssh.privkey.path = <secrets/ssh.id_ed25519>;
@@ -233,6 +258,13 @@ in
-----END RSA PUBLIC KEY-----
'';
};
+ wirelum = {
+ ip6.addr = (wip6 "1205").address;
+ aliases = [
+ "icarus.w"
+ ];
+ wireguard.pubkey = "mVe3YdlWOlVF5+YD5vgNha3s03dv6elmNVsARtPLXQQ=";
+ };
};
secure = true;
ssh.privkey.path = <secrets/ssh.id_ed25519>;
@@ -429,6 +461,13 @@ in
-----END PUBLIC KEY-----
'';
};
+ wirelum = {
+ ip6.addr = (wip6 "e110").address;
+ aliases = [
+ "yellow.w"
+ ];
+ wireguard.pubkey = "YeWbR3mW+nOVBE7bcNSzF5fjj9ppd8OGHBJqERAUVxU=";
+ };
};
ssh.privkey.path = <secrets/ssh.id_ed25519>;
ssh.pubkey = "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIC03TCO73NQZHo7NKZiVJp2iiUbe6PQP14Kg3Bnlkqje ";