summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/konsens.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2023-06-03 15:50:01 +0200
committermakefu <github@syntax-fehler.de>2023-06-03 15:50:01 +0200
commit15f4d5f29d3a4b662376f362d21e5b163bd7c5e1 (patch)
tree77b0239c8899207b76fdef85090db7aa2b6e3eea /krebs/3modules/konsens.nix
parent563b55fa133a38aacff93747773f026b0681eece (diff)
parent7c3b3400b71678617ac042b522c26e747b8312c2 (diff)
Merge remote-tracking branch 'lassul.us/master'
Diffstat (limited to 'krebs/3modules/konsens.nix')
-rw-r--r--krebs/3modules/konsens.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/krebs/3modules/konsens.nix b/krebs/3modules/konsens.nix
index 439bcc7f..81dbb33e 100644
--- a/krebs/3modules/konsens.nix
+++ b/krebs/3modules/konsens.nix
@@ -60,12 +60,17 @@ let
systemd.services = mapAttrs' (name: repo:
nameValuePair "konsens-${name}" {
after = [ "network.target" ];
- path = [ pkgs.git ];
+ path = [
+ pkgs.git
+ pkgs.openssh
+ ];
restartIfChanged = false;
serviceConfig = {
Type = "simple";
PermissionsStartOnly = true;
ExecStart = pkgs.writeDash "konsens-${name}" ''
+ set -efu
+ git config --global --replace-all safe.directory *
if ! test -e ${name}; then
git clone ${repo.url} ${name}
fi