summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/external/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-12-19 14:25:03 +0100
committermakefu <github@syntax-fehler.de>2018-12-19 14:25:03 +0100
commitd0a02bf54d6538a027f619f83fe895cbfdf4b366 (patch)
tree6d9683236d0cd14f4a52ecc692f4618aa63ffc57 /krebs/3modules/external/default.nix
parentb7529f97e118f1b4da91acae2c21a06eae6e5638 (diff)
external: move users from makefu namespace to external
Diffstat (limited to 'krebs/3modules/external/default.nix')
-rw-r--r--krebs/3modules/external/default.nix26
1 files changed, 21 insertions, 5 deletions
diff --git a/krebs/3modules/external/default.nix b/krebs/3modules/external/default.nix
index 39922e2e..7b651f6f 100644
--- a/krebs/3modules/external/default.nix
+++ b/krebs/3modules/external/default.nix
@@ -9,6 +9,7 @@ with import <stockholm/lib>;
nets.retiolum.ip6.addr =
(krebs.genipv6 "retiolum" "external" { inherit hostName; }).address;
});
+ pub-for = name: builtins.readFile (./ssh + "/${name}.pub");
in {
hosts = mapAttrs hostDefaults {
@@ -316,19 +317,34 @@ in {
};
};
users = {
- Mic92 = {
- pubkey = "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIKbBp2dH2X3dcU1zh+xW3ZsdYROKpJd3n13ssOP092qE";
- mail = "joerg@higgsboson.tk";
+ ciko = {
+ mail = "wieczorek.stefan@googlemail.com";
+ };
+ exco = {
+ mail = "dickbutt@excogitation.de";
+ pubkey = pub-for "exco";
};
kmein = {
};
- palo = {
+ Mic92 = {
+ mail = "joerg@higgsboson.tk";
+ pubkey = pub-for "Mic92";
};
- sokratess = {
+ palo = {
};
qubasa = {
mail = "luis.nixos@gmail.com";
};
+ raute = {
+ mail = "macxylo@gmail.com";
+ pubkey = pub-for "raute";
+ };
+ sokratess = {
+ };
+ ulrich = {
+ mail = "shackspace.de@myvdr.de";
+ pubkey = pub-for "ulrich";
+ };
};
}