summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/external/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-12-19 14:41:56 +0100
committermakefu <github@syntax-fehler.de>2018-12-19 14:41:56 +0100
commit337761712a00c4f90ea3fabc228bf5d494f357e5 (patch)
tree48acf0c24022ce4473f67a47ca60533adfc3a651 /krebs/3modules/external/default.nix
parent30654e46c67e99d67c5e247f8e92050cc3087e0e (diff)
external: move tpsw from makefu, add justraute
Diffstat (limited to 'krebs/3modules/external/default.nix')
-rw-r--r--krebs/3modules/external/default.nix36
1 files changed, 31 insertions, 5 deletions
diff --git a/krebs/3modules/external/default.nix b/krebs/3modules/external/default.nix
index ee1dbf4e..fc450b66 100644
--- a/krebs/3modules/external/default.nix
+++ b/krebs/3modules/external/default.nix
@@ -9,7 +9,8 @@ with import <stockholm/lib>;
nets.retiolum.ip6.addr =
(krebs.genipv6 "retiolum" "external" { inherit hostName; }).address;
});
- pub-for = name: builtins.readFile (./ssh + "/${name}.pub");
+ ssh-for = name: builtins.readFile (./ssh + "/${name}.pub");
+ tinc-for = name: builtins.readFile (./tinc + "/${name}.pub");
in {
hosts = mapAttrs hostDefaults {
@@ -137,6 +138,18 @@ in {
};
};
};
+ justraute = {
+ owner = config.krebs.users.raute; # laptop
+ nets = {
+ retiolum = {
+ ip4.addr = "10.243.183.231";
+ aliases = [
+ "justraute.r"
+ ];
+ tinc.pubkey = tinc-for "justraute";
+ };
+ };
+ };
kruck = {
owner = config.krebs.users.palo;
nets = {
@@ -260,6 +273,19 @@ in {
};
};
};
+ tpsw = {
+ cores = 2;
+ owner = config.krebs.users.ciko; # main laptop
+ nets = {
+ retiolum = {
+ ip4.addr = "10.243.183.236";
+ aliases = [
+ "tpsw.r"
+ ];
+ tinc.pubkey = tinc-for "tpsw";
+ };
+ };
+ };
turingmachine = {
owner = config.krebs.users.Mic92;
nets = {
@@ -322,13 +348,13 @@ in {
};
exco = {
mail = "dickbutt@excogitation.de";
- pubkey = pub-for "exco";
+ pubkey = ssh-for "exco";
};
kmein = {
};
Mic92 = {
mail = "joerg@higgsboson.tk";
- pubkey = pub-for "Mic92";
+ pubkey = ssh-for "Mic92";
};
palo = {
};
@@ -337,13 +363,13 @@ in {
};
raute = {
mail = "macxylo@gmail.com";
- pubkey = pub-for "raute";
+ pubkey = ssh-for "raute";
};
sokratess = {
};
ulrich = {
mail = "shackspace.de@myvdr.de";
- pubkey = pub-for "ulrich";
+ pubkey = ssh-for "ulrich";
};
};
}