summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/dns.nix
diff options
context:
space:
mode:
authorlassulus <git@lassul.us>2023-06-10 12:50:53 +0200
committerlassulus <git@lassul.us>2023-06-11 16:50:45 +0200
commit9cc3eea82d60dc5ed9f4de7c15d63ee162e639fb (patch)
tree072eac849a03ecb4c95efc575ca1efe326da3a89 /krebs/3modules/dns.nix
parent98584f2db914208bf6db482627cdb7de151d2d89 (diff)
init flake.nix
Diffstat (limited to 'krebs/3modules/dns.nix')
-rw-r--r--krebs/3modules/dns.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/krebs/3modules/dns.nix b/krebs/3modules/dns.nix
index 8a74d306..60e084f5 100644
--- a/krebs/3modules/dns.nix
+++ b/krebs/3modules/dns.nix
@@ -1,5 +1,5 @@
-with import <stockholm/lib>;
-{ config, ... }: {
+{ config, lib, pkgs, ... }:
+with pkgs.stockholm.lib; {
options = {
krebs.dns.providers = mkOption {
type = types.attrsOf types.str;
@@ -8,7 +8,7 @@ with import <stockholm/lib>;
type = types.nullOr types.hostname;
};
};
- config = mkIf config.krebs.enable {
+ config = lib.mkIf config.krebs.enable {
krebs.dns.providers = {
"krebsco.de" = "zones";
shack = "hosts";