summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-22 20:14:01 +0200
committertv <tv@shackspace.de>2015-10-22 20:14:01 +0200
commit128e5feae9829ec1c60d16f3d44382435ff1ef86 (patch)
treef98601e8408a8f949022d86610828afef6836e0f /krebs/3modules/default.nix
parent9ba8fc142cb14aa3768cb99bf9170f7875beafd1 (diff)
parentf092e6acb4500569eccee7aed65b521adb3b07b6 (diff)
Merge remote-tracking branch 'pnp/master'
Diffstat (limited to 'krebs/3modules/default.nix')
-rw-r--r--krebs/3modules/default.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/krebs/3modules/default.nix b/krebs/3modules/default.nix
index e2aea705..e244ef7b 100644
--- a/krebs/3modules/default.nix
+++ b/krebs/3modules/default.nix
@@ -6,6 +6,7 @@ let
out = {
imports = [
+ ./bepasty-server.nix
./build.nix
./exim-retiolum.nix
./exim-smarthost.nix
@@ -14,8 +15,10 @@ let
./iptables.nix
./nginx.nix
./Reaktor.nix
+ ./retiolum-bootstrap.nix
./realwallpaper.nix
./retiolum.nix
+ ./tinc_graphs.nix
./urlwatch.nix
];
options.krebs = api;
@@ -102,10 +105,14 @@ let
# Implements environment.etc."zones/<zone-name>"
environment.etc = let
+ stripEmptyLines = s: concatStringsSep "\n"
+ (remove "\n" (remove "" (splitString "\n" s)));
all-zones = foldAttrs (sum: current: sum + "\n" +current ) ""
- ([cfg.zone-head-config] ++ combined-hosts) ;
+ ([cfg.zone-head-config] ++ combined-hosts);
combined-hosts = (mapAttrsToList (name: value: value.extraZones) cfg.hosts );
- in lib.mapAttrs' (name: value: nameValuePair (("zones/" + name)) ({ text=value; })) all-zones;
+ in lib.mapAttrs' (name: value: nameValuePair
+ ("zones/" + name)
+ { text=(stripEmptyLines value); }) all-zones;
krebs.exim-smarthost.internet-aliases = let
format = from: to: