summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/charybdis.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2020-01-14 20:37:58 +0100
committertv <tv@krebsco.de>2020-01-14 20:37:58 +0100
commita553c3e2803cceecc6e6f42dbcba6a179035274e (patch)
treeae8c1d1ed717614d2da7293efbfa1d8b71f1ec5b /krebs/3modules/charybdis.nix
parentc515d6c9740238ec5d5ec916262b487e97883fee (diff)
charybdis: types.{string => str}
Diffstat (limited to 'krebs/3modules/charybdis.nix')
-rw-r--r--krebs/3modules/charybdis.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/krebs/3modules/charybdis.nix b/krebs/3modules/charybdis.nix
index f4a7c131..aa7c980c 100644
--- a/krebs/3modules/charybdis.nix
+++ b/krebs/3modules/charybdis.nix
@@ -21,14 +21,14 @@ in
enable = mkEnableOption "Charybdis IRC daemon";
config = mkOption {
- type = types.string;
+ type = types.str;
description = ''
Charybdis IRC daemon configuration file.
'';
};
statedir = mkOption {
- type = types.string;
+ type = types.str;
default = "/var/lib/charybdis";
description = ''
Location of the state directory of charybdis.
@@ -36,7 +36,7 @@ in
};
user = mkOption {
- type = types.string;
+ type = types.str;
default = "ircd";
description = ''
Charybdis IRC daemon user.
@@ -44,7 +44,7 @@ in
};
group = mkOption {
- type = types.string;
+ type = types.str;
default = "ircd";
description = ''
Charybdis IRC daemon group.