summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/reaktor-krebs.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-10-07 11:56:36 +0200
committerlassulus <lassulus@lassul.us>2017-10-07 11:56:36 +0200
commit1124548642eeda9225cd223b2c4de12e0240d02f (patch)
tree9cbab679532c8121586eecedc235d73ef3f40f29 /krebs/2configs/reaktor-krebs.nix
parenta8db051451d2827d7c7ad38f005284013e63c039 (diff)
move Reaktors to hotdog.r
Diffstat (limited to 'krebs/2configs/reaktor-krebs.nix')
-rw-r--r--krebs/2configs/reaktor-krebs.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/krebs/2configs/reaktor-krebs.nix b/krebs/2configs/reaktor-krebs.nix
new file mode 100644
index 00000000..6b17b457
--- /dev/null
+++ b/krebs/2configs/reaktor-krebs.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+with import <stockholm/lib>;
+
+{
+ krebs.Reaktor.krebs = {
+ nickname = "Reaktor|krebs";
+ channels = [
+ "#krebs"
+ "#nixos-wiki"
+ ];
+ extraEnviron = {
+ REAKTOR_HOST = "irc.freenode.org";
+ };
+ plugins = with pkgs.ReaktorPlugins; [
+ sed-plugin
+ wiki-todo-add
+ wiki-todo-done
+ wiki-todo-show
+ ];
+ };
+ services.nginx.virtualHosts."lassul.us".locations."/wiki-todo".extraConfig = ''
+ default_type "text/plain";
+ alias /var/lib/Reaktor/state/wiki-todo;
+ '';
+}