summaryrefslogtreecommitdiffstats
path: root/jeschli/2configs/own-pkgs/rmount/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2019-11-12 19:18:31 +0100
committertv <tv@krebsco.de>2019-11-12 19:18:31 +0100
commiteaefd713c281e8802e4ff902b35a17b8b39f2b16 (patch)
treeed7521ae3c0c49dce87045c213618179042174ae /jeschli/2configs/own-pkgs/rmount/default.nix
parent46cdc3ed4238965553d734b614b212fd96cba447 (diff)
parent4b5e3cbc6155ee807a9b6c474972df3e4fcd237b (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'jeschli/2configs/own-pkgs/rmount/default.nix')
-rw-r--r--jeschli/2configs/own-pkgs/rmount/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/jeschli/2configs/own-pkgs/rmount/default.nix b/jeschli/2configs/own-pkgs/rmount/default.nix
new file mode 100644
index 00000000..22631f42
--- /dev/null
+++ b/jeschli/2configs/own-pkgs/rmount/default.nix
@@ -0,0 +1,34 @@
+{ stdenv, fetchgit, makeWrapper, lib, pkgs ? import <nixpkgs> {} }:
+with pkgs;
+
+stdenv.mkDerivation rec {
+ name = "rmount-${version}";
+ version = "1.0.1";
+ rev = "v${version}";
+
+ src = fetchgit {
+ rev = "9df124780d2e66f01c70afaecf92090669c5ffb6";
+ url = "https://github.com/Luis-Hebendanz/rmount";
+ sha256 = "0ydb6sspfnfa3y6gg1r8sk4r58il6636lpqwb2rw7dzmb4b8hpd2";
+ };
+
+ buildInputs = [ stdenv makeWrapper ];
+
+ installPhase = ''
+ mkdir -p $out/bin
+ mkdir -p $out/share/man/man1
+ cp ${src}/rmount.man $out/share/man/man1/rmount.1
+ cp ${src}/rmount.bash $out/bin/rmount-noenv
+ cp ${src}/config.json $out/share/config.json
+ chmod +x $out/bin/rmount-noenv
+
+ makeWrapper $out/bin/rmount-noenv $out/bin/rmount \
+ --prefix PATH : ${lib.makeBinPath [ nmap jq cifs-utils sshfs ]}
+ '';
+
+ meta = {
+ homepage = "https://github.com/Luis-Hebendanz/rmount";
+ description = "Remote mount utility which parses a json file";
+ license = stdenv.lib.licenses.mit;
+ };
+}