summaryrefslogtreecommitdiffstats
path: root/jeschli/1systems/reagenzglas/config.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2019-10-14 17:02:20 +0200
committerlassulus <lassulus@lassul.us>2019-10-14 17:02:20 +0200
commita707ca0e2e3c1ffcc09647cac9a9d9357f85314a (patch)
tree88e6286eb4f90500d4571aa5dbbd2a36b49a8bf0 /jeschli/1systems/reagenzglas/config.nix
parent9722a91761b7fd68704c1c69be7df2952d4f4a41 (diff)
parent7d5a58cd02e85abdf53c7cebaf295ff8a175e61e (diff)
Merge remote-tracking branch 'enklave/master' into 19.0919.09
Diffstat (limited to 'jeschli/1systems/reagenzglas/config.nix')
-rw-r--r--jeschli/1systems/reagenzglas/config.nix25
1 files changed, 4 insertions, 21 deletions
diff --git a/jeschli/1systems/reagenzglas/config.nix b/jeschli/1systems/reagenzglas/config.nix
index 2eefb23f..b56b76ac 100644
--- a/jeschli/1systems/reagenzglas/config.nix
+++ b/jeschli/1systems/reagenzglas/config.nix
@@ -1,23 +1,11 @@
{ config, pkgs, ... }:
-with pkgs;
-let
- rebuild_script = pkgs.writeTextFile {
- name="rebuild";
- text=''
- #!/usr/bin/env sh
- set -eu
- sudo cp -r /etc/nixos ~/old-nixos
- sudo cp -r $HOME/nixos /etc/
- sudo nixos-rebuild switch
- '';
- executable=true;
- };
-in
+
{
imports =
[
<stockholm/jeschli>
<stockholm/jeschli/2configs/emacs.nix>
+ <stockholm/jeschli/2configs/python.nix>
./desktop.nix
./i3-configuration.nix
./hardware-configuration.nix
@@ -27,7 +15,7 @@ in
boot.loader.systemd-boot.enable = true;
# Wireless network with network manager
- krebs.build.host = config.krebs.hosts.brauerei;
+ krebs.build.host = config.krebs.hosts.reagenzglas;
# networking.hostName = "nixos"; # Define your hostname.
networking.networkmanager.enable = true;
@@ -49,14 +37,9 @@ in
wget vim git
firefox
rofi
+ ag
];
- # How I rebuild the system
- environment.shellAliases = {
- rebuild = rebuild_script;
- };
-
- # Define a user account. Don't forget to set a password with ‘passwd’.
users.users.ombi = {
isNormalUser = true;
extraGroups = [ "wheel" ]; # Enable ‘sudo’ for the user.