summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-22 00:20:16 +0200
committertv <tv@shackspace.de>2015-10-22 00:22:30 +0200
commitfc64fd18cb8677f08d038a086de879fd69f89b8c (patch)
tree13823bf6fbc6acf50dd794a2a845bbe951c7a030 /default.nix
parent5206c11026245b1fe20a66fb5b14165e51195f0b (diff)
krebs.*: make StrictHostKeyChecking configurable
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index fc322cb8..b261e51e 100644
--- a/default.nix
+++ b/default.nix
@@ -17,7 +17,8 @@
{ current-date ? abort "current-date not defined"
, current-host-name ? abort "current-host-name not defined"
, current-user-name ? builtins.getEnv "LOGNAME"
-}@current:
+, StrictHostKeyChecking ? "yes"
+}@args:
let stockholm = {
# The generated scripts to deploy (or infest) systems can be found in the
@@ -47,7 +48,7 @@ let stockholm = {
inherit pkgs;
};
- krebs = import ./krebs (current // { inherit lib stockholm; });
+ krebs = import ./krebs (args // { inherit lib stockholm; });
lib =
let