summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-11-06 22:05:36 +0100
committertv <tv@krebsco.de>2015-11-06 22:07:12 +0100
commitf559b19bec61730c537cdd76233304e66c3f497a (patch)
tree8c52431670222758c6da367fd0869ccce17feb59 /default.nix
parent0bf6e55f77cffb4ca65c6926eea7bc77140574a5 (diff)
stockholm: import default user config
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 472d7597..ac748c28 100644
--- a/default.nix
+++ b/default.nix
@@ -32,7 +32,10 @@ let stockholm = {
upath = lib.nspath current-user-name;
base-module = { config, ... }: {
- imports = map (f: f "3modules") [ kpath upath ];
+ imports = builtins.filter builtins.pathExists (lib.concatLists [
+ (map (f: f "2configs") [ upath ])
+ (map (f: f "3modules") [ kpath upath ])
+ ]);
krebs.current.enable = true;
krebs.current.host = config.krebs.hosts.${current-host-name};