summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-01 01:48:15 +0200
committertv <tv@shackspace.de>2015-10-01 02:19:13 +0200
commitbfe0723728ae2d995b99f22fe9783a34889b1828 (patch)
tree8b8a17ae2431e61890d8ac84f74715e8394e15c3 /default.nix
parent60be21be0a06687b22af02d0bbce606860d00638 (diff)
move config scripts to krebs
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix31
1 files changed, 12 insertions, 19 deletions
diff --git a/default.nix b/default.nix
index 1c3341ba..7f3f621b 100644
--- a/default.nix
+++ b/default.nix
@@ -1,36 +1,29 @@
-{ user-name, host-name }:
+{ current-date
+, current-host-name
+, current-user-name
+}:
let
lib = import <nixpkgs/lib>;
krebs-modules-path = ./krebs/3modules;
krebs-pkgs-path = ./krebs/5pkgs;
- user-modules-path = ./. + "/${user-name}/3modules";
- user-pkgs-path = ./. + "/${user-name}/5pkgs";
+ user-modules-path = ./. + "/${current-user-name}/3modules";
+ user-pkgs-path = ./. + "/${current-user-name}/5pkgs";
out =
- (lib.mapAttrs (k: v: mk-namespace (./. + "/${k}"))
+ (lib.mapAttrs
+ (k: v:
+ if builtins.pathExists (./. + "/${k}/1systems")
+ then mk-namespace (./. + "/${k}")
+ else import (./. + "/${k}"))
(lib.filterAttrs
- (k: v: !lib.hasPrefix "." k && v == "directory" &&
- builtins.pathExists (./. + "/${k}/1systems"))
+ (k: v: !lib.hasPrefix "." k && v == "directory")
(builtins.readDir ./.)));
eval = path: import <nixpkgs/nixos/lib/eval-config.nix> {
system = builtins.currentSystem;
modules = [
- ({ config, ... }:
- with import ./krebs/4lib { inherit lib; };
- {
- options.krebs.exec.host = mkOption {
- type = types.host;
- default = config.krebs.hosts.${host-name};
- };
- options.krebs.exec.user = mkOption {
- type = types.user;
- default = config.krebs.users.${user-name};
- };
- }
- )
path
krebs-modules-path
user-modules-path