summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-17 07:25:10 +0200
committertv <tv@shackspace.de>2015-10-17 07:25:10 +0200
commitaa094e2b81910455e2385c78727da13f03074913 (patch)
treeffdac0fa420ff6a9aae41451693fdda768ad6c5f /default.nix
parent4e4e1696462087925ba38b7ff2bf73cdad468009 (diff)
default out: use nspath in namespace loader
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/default.nix b/default.nix
index c7365fd5..fd127084 100644
--- a/default.nix
+++ b/default.nix
@@ -27,9 +27,9 @@ let
{ inherit (eval {}) config options pkgs; } //
lib.mapAttrs
(name: _:
- if builtins.pathExists (./. + "/${name}/default.nix")
- then import (./. + "/${name}")
- else import-1systems (./. + "/${name}/1systems"))
+ if builtins.pathExists (nspath name "default.nix")
+ then import (nspath name "default.nix")
+ else import-1systems (nspath name "1systems"))
(lib.filterAttrs
(n: t: !lib.hasPrefix "." n && t == "directory")
(builtins.readDir ./.));