summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-25 14:15:21 +0100
committertv <tv@shackspace.de>2015-10-25 14:15:21 +0100
commit8f15daf2ea25304e9cbc8d449fb92078b2fb6f03 (patch)
tree7291d63e67340d31b3be8677fe2f8c56e8f3b653 /default.nix
parentdaa8fe2aa83451e7d4fc120f7fd417409ac2666c (diff)
init krebs.current
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index c7846419..472d7597 100644
--- a/default.nix
+++ b/default.nix
@@ -31,9 +31,13 @@ let stockholm = {
kpath = lib.nspath "krebs";
upath = lib.nspath current-user-name;
- base-module = {
+ base-module = { config, ... }: {
imports = map (f: f "3modules") [ kpath upath ];
+ krebs.current.enable = true;
+ krebs.current.host = config.krebs.hosts.${current-host-name};
+ krebs.current.user = config.krebs.users.${current-user-name};
+
nixpkgs.config.packageOverrides = pkgs:
let
kpkgs = import (kpath "5pkgs") { inherit lib pkgs; };