summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-21 22:29:35 +0200
committertv <tv@shackspace.de>2015-10-21 22:29:35 +0200
commit714a2e492270d984e8987532c247ae4caf69fce0 (patch)
treef48cd307092188bc0e1519a1c13494c473a9e693 /default.nix
parentb55f07e57af69f918182405d473d22981c515b86 (diff)
stockholm: only inherit in out
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index c7022517..fc322cb8 100644
--- a/default.nix
+++ b/default.nix
@@ -44,7 +44,7 @@ let stockholm = {
# Additionally, output lib and pkgs for easy access from the shell.
# Notice how we're evaluating just the base module to obtain pkgs.
inherit lib;
- inherit (eval {}) pkgs;
+ inherit pkgs;
};
krebs = import ./krebs (current // { inherit lib stockholm; });
@@ -62,6 +62,8 @@ let stockholm = {
nspath = ns: p: stockholm-path + "/${ns}/${p}";
};
+ inherit (eval {}) pkgs;
+
# Path resolvers for common and individual files.
# Example: `upath "3modules"` produces the current user's 3modules directory
kpath = lib.nspath "krebs";