summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-02 15:29:47 +0200
committertv <tv@shackspace.de>2015-10-02 15:29:47 +0200
commit5b719cfd5e75f105a10b3fe6827f8d2aceb95693 (patch)
tree2f662662acd73b7279796cbae9fca1d264c89b6b /default.nix
parent655f510425848b2718773372ce7d6f297276ccce (diff)
default.nix: export get
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index c6a635c2..f14329d4 100644
--- a/default.nix
+++ b/default.nix
@@ -11,7 +11,21 @@ let
user-modules-path = ./. + "/${current-user-name}/3modules";
user-pkgs-path = ./. + "/${current-user-name}/5pkgs";
+ # XXX This is only used interactively, e.g. using get.
+ pkgs =
+ let
+ pkgs = import <nixpkgs> {};
+ args = {
+ inherit pkgs;
+ lib = pkgs.lib;
+ };
+ in
+ pkgs //
+ import krebs-pkgs-path args //
+ import user-pkgs-path args;
+
out =
+ { inherit pkgs; } //
lib.mapAttrs (_: builtins.getAttr "main")
(lib.filterAttrs (_: builtins.hasAttr "main")
(lib.mapAttrs