summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-24 15:15:57 +0200
committertv <tv@shackspace.de>2015-10-24 15:15:57 +0200
commitabcfba84ca375f868f84188aed704be26d145221 (patch)
tree4a339d8cd7cdde60e55ff018906358178b204161 /default.nix
parentcc59f4d6b640752c1277ec3bdfca88404c3b4357 (diff)
stockholm: lol literate
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix55
1 files changed, 0 insertions, 55 deletions
diff --git a/default.nix b/default.nix
index b261e51e..c7846419 100644
--- a/default.nix
+++ b/default.nix
@@ -1,19 +1,3 @@
-# Welcome to the top-level default.nix of stockholm.
-#
-# You can discover the whole thing easily using the `get` utility,
-# which can be found at http://cgit.cd.krebsco.de/get/tree/get
-# To install `get` on any Nix-enabled system, use:
-#
-# nix-env -f /path/to/stockholm -iA pkgs.get
-#
-# The "current" arguments are used to provide information about the user who's
-# evaluating this file. This information is used to determine which user
-# namespace is to be used. Of course there's nothing trying to prevent you
-# from forging this information. E.g. you could try to generate the deployment
-# script for some random user's system, targeting some random host:
-#
-# LOGNAME=tv get krebs.deploy system=nomic target=8.8.8.8
-#
{ current-date ? abort "current-date not defined"
, current-host-name ? abort "current-host-name not defined"
, current-user-name ? builtins.getEnv "LOGNAME"
@@ -21,29 +5,8 @@
}@args:
let stockholm = {
- # The generated scripts to deploy (or infest) systems can be found in the
- # `krebs` attribute. There's also an init script, but it's in its early
- # stages, not well integrated and mostly useless at the moment. :)
- #
- # You'll also find lib here, which is nixpkgs/lib + krebs lib, but nobody
- # is really accessing this directly, as this lib gets reexported below.
inherit krebs;
-
- # All systems of all users can be found here.
- #
- # /!\ Please note that `get users.${user-name}.${host-name}.system` is a
- # bad idea because it will produce vast amounts of output. These are the
- # actual and complete system derivations that can be installed on the
- # respective host.
- #
- # Another thing to notice here is that other user's systems might not be
- # evaluable because of missing secrets. If you _are_ able to evaluate
- # another user's system, then you probably share a similar naming scheme
- # for your secret files! :)
inherit users;
-
- # Additionally, output lib and pkgs for easy access from the shell.
- # Notice how we're evaluating just the base module to obtain pkgs.
inherit lib;
inherit pkgs;
};
@@ -65,32 +28,20 @@ let stockholm = {
inherit (eval {}) pkgs;
- # Path resolvers for common and individual files.
- # Example: `upath "3modules"` produces the current user's 3modules directory
kpath = lib.nspath "krebs";
upath = lib.nspath current-user-name;
- # This is the base module. Its purpose is to provide modules and
- # packages, both common ones, found in krebs/ as well as the current user's,
- # found in the user's namespace.
base-module = {
imports = map (f: f "3modules") [ kpath upath ];
nixpkgs.config.packageOverrides = pkgs:
let
- # Notice the ordering. Krebs packages can only depend on Nixpkgs,
- # whereas user packages additionally can depend on krebs packages.
kpkgs = import (kpath "5pkgs") { inherit lib pkgs; };
upkgs = import (upath "5pkgs") { inherit lib; pkgs = pkgs // kpkgs; };
in
kpkgs // upkgs;
};
- # The above base module is used together with a NixOS configuration to
- # produce a system. Notice how stockholm really just provides additional
- # packages and modules on top of NixOS. Some of this stuff might become
- # useful to a broader audience, at which point it should probably be merged
- # and pull-requested for inclusion into NixOS/nixpkgs.
eval = config: import <nixpkgs/nixos/lib/eval-config.nix> {
specialArgs = {
inherit lib;
@@ -101,10 +52,6 @@ let stockholm = {
];
};
- # Any top-level directory other than krebs/ is considered to be a user
- # namespace, configuring a bunch of systems.
- # Have a look at the definition of install in krebs/default.nix to see how
- # nix-env is using this attribute set to obtain the system to be installed.
# TODO move user namespaces' to users/, so no exception for krebs/ is needed
users =
lib.mapAttrs
@@ -113,8 +60,6 @@ let stockholm = {
(n: t: !lib.hasPrefix "." n && t == "directory" && n != "krebs")
(builtins.readDir ./.));
- # Given a path to a user namespace, provide an attribute of evaluated
- # system configurations, keyed by system names (AKA host names).
eval-all-systems = path:
lib.mapAttrs'
(n: _: (lib.nameValuePair (lib.removeSuffix ".nix" n)